PDA

View Full Version : [Help - Video] AVI Subs problem



Xombii
10-16-2009, 12:10 AM
hiya i just dled a movie but the subs are like 1 or 2 sec off the audio. its really bugging me:banghead: is there anyway to slow down the subs? The subs are hard coded into the avi file.

Aku no Hikari
10-16-2009, 03:01 AM
If the subs in the AVI file are mixed with the video, there's nothing that you can do about it. If they are not, it depends.

If you want a temporary solution, your media player or codec should have some subtitles CP or something. For example, if you use the K-Lite codec pack, you can open "ffdshow video decoder" (under Configuration from the K-Lite codec pack's start menu group), click "Subtitles" (to the left, and make sure it's ticked) and then change the "Delay" field to either a positive or negative value (which makes them appear earlier or later).

If you're not using K-Lite codec pack, your codec or media player should have some options for that. If you don't know how to configure that, please tell us what media player and codec you're using and I'll see if I can help.

However, if what you want to do is change the subtitles in the file itself, you'll need some program for that. I haven't done this myself before, so I can't give you suggestions about which program to use.

Gjallarhorn
10-16-2009, 05:48 PM
With .avi files, subtitles are only able to be hardcoded onto the video itself - that is, they are now a part of the video itself, and cannot be removed. So for your situation you are stuck.

What is possible is to save the audio as a separate track, and then re-add the audio to the video steam using any decent video editing program. This should be relatively easy in VirtualDub. After you've finished setting the audio track and aligning it properly, you just need to make sure you compress the audio and video appropriately (under Video>Full Processing and Audio>Full Processing), otherwise you'll end up with a ridiculously large video file.

Xombii
10-16-2009, 05:55 PM
ok thanks guys